Meddelande

Minska
No announcement yet.

Tar inte mina cgi-script

Minska
X
 
  • Filter
  • Klockan
  • Show
Clear All
new posts

  • Tar inte mina cgi-script

    Hur ska jag konfigurera min linuxserver för att den ska kunna äta mina cgi-script? Om jag lägger filerna i /usr/lib/cgi-bin o försöker komma åt dom via url: http.../cgi-bin/fil.cgi så får jag bara felmeddelande ala "500 Internal Server Error".

    Jag vill även kunna lägga cgi-script i andra kataloger, typ hemkataloger, och det gör jag tydligen genom att lägga till en fil .htaccess i den katalog jag vill ha cgi-script i och sedan skriva i den: Options +ExecCGI

    Gjorde detta, men får precis samma fel när jag försöker köra script som ligger i den katalogen. Har provat med ett litet hello world-cgi-script som jag hittade och det blir samma fel, alltså verkar det inte vara något fel i koden iaf.

    Ja, jag har använt sökfunktionen här på wF
    Last edited by Gein; 2002-12-11, 15:33.
    The future is today, worry about it tomorrow

  • #2
    Har du rätt sökväg till perl? (första raden i scriptet)

    Har du överfört scripten i ASCII-format?

    Har du gett scripten rätt rättigheter? (tex. 755 eller 777)
    /Patrik
    "Den som har rent samvete har ofta bara dåligt minne"

    Kommentera


    • #3
      Ja, rätt sökväg. Filerna är skapade på servern så det torde inte vara något problem och jag testade nu med rättigheter 777. Ingen skillnad. Det verkar inte ens ha med scriptet att göra. För bara jag försöker gå in på katalogen, utan att ange någon fil i URLn så får jag det där felmeddelandet:

      http://www.knivby.nu/~gein/sml/tenta/julmust/
      http://www.knivby.nu/~gein/sml/tenta/julmust/first.pl

      Borde vara någon inställning nånstans?

      r) http://www.knivby.nu/cgi-bin/first.pl <- ger samma fel
      The future is today, worry about it tomorrow

      Kommentera


      • #4
        Ta en titt i apaches error_log. där finns det nästan säkert ledtrådar
        Med dagens datorer kan du göra fler fel per sekund än någonsin tidigare!

        Sendmail är rooten till root!

        Kommentera


        • #5
          Så här tycker felloggen:
          [citat]
          [Wed Dec 11 07:54:28 2002] [error] (13)Permission denied: exec of /usr/lib/cgi-bin/first.pl failed
          [Wed Dec 11 07:54:28 2002] [error] [client 192.168.0.102] Premature end of script headers: /usr/lib/cgi-bin/first.pl
          [Wed Dec 11 07:54:29 2002] [error] (13)Permission denied: exec of /usr/lib/cgi-bin/first.pl failed
          [Wed Dec 11 07:54:29 2002] [error] [client 192.168.0.102] Premature end of script headers: /usr/lib/cgi-bin/first.pl
          [/citat]
          The future is today, worry about it tomorrow

          Kommentera


          • #6
            Har du provat att sätta +ExecCGI direkt i httpd.conf?

            Exempel.

            (Flyttar tråden till Apache-forumet)

            (Red. url)
            Last edited by Jojoxx; 2002-12-11, 20:14.
            / Jojoxx

            "Always remember that you're unique and special, just like everyone else..."

            Kommentera


            • #7
              det hjälpte inte heller.. hmm, vad är på tok!
              The future is today, worry about it tomorrow

              Kommentera


              • #8
                om jag försöker köra en fil som ligger under min public_html i en katalog där jag satt rättigheter med .htaccess så får jag följande fel
                [citat]
                [Wed Dec 11 14:45:34 2002] [alert] [client 192.168.0.102] /home/gein/public_html/sml/tenta/julmust/.htaccess: Options not allowed here
                [/citat]

                om jag istället försöker i /cgi-bin/ katalogen så får jag följande fel:

                [citat]
                [Wed Dec 11 14:45:40 2002] [error] (8)Exec format error: exec of /usr/lib/cgi-bin/first.pl failed
                [Wed Dec 11 14:45:40 2002] [error] [client 192.168.0.102] Premature end of script headers: /usr/lib/cgi-bin/first.pl
                [/citat]
                The future is today, worry about it tomorrow

                Kommentera


                • #9
                  Hur ser AllowOverride ut i httpd.conf?
                  Vissa dagar är man asfalten, andra dagar är man ångvälten.
                  Vissa dagar är man myggan, andra dagar är man vindrutan.

                  XML är som våld; löser det inte ens problem betyder det att man använder för lite.

                  Kommentera


                  • #10
                    den säger AllowOverride All, men ligger under
                    <Directory /var/www/>

                    och den mapp jag pratar om ligger här: /home/gein/public_html/sml/tenta/julmust
                    The future is today, worry about it tomorrow

                    Kommentera


                    • #11
                      okej, nu fick jag nog till det med den mappen oxå, men även den säger såhär:

                      [citat]
                      [Wed Dec 11 15:07:17 2002] [error] [client 192.168.0.102] Premature end of script headers: /home/gein/public_html/sml/tenta/julmust/first.pl
                      [/citat]
                      The future is today, worry about it tomorrow

                      Kommentera


                      • #12
                        Det kan bero på något fel som inträffar, typ syntaxfel eller liknande. Prova med enklast tänkbara script:
                        [kod]
                        #!/usr/bin/perl

                        print "Content-Type:text/plain\n\nHello, world!";
                        [/kod] ... och se vad som händer.
                        Vissa dagar är man asfalten, andra dagar är man ångvälten.
                        Vissa dagar är man myggan, andra dagar är man vindrutan.

                        XML är som våld; löser det inte ens problem betyder det att man använder för lite.

                        Kommentera


                        • #13
                          kopierade exakt din kod och fick samma fel:

                          [Wed Dec 11 15:12:10 2002] [error] [client 192.168.0.102] Premature end of script headers: /home/gein/public_html/sml/tenta/julmust/test.pl
                          The future is today, worry about it tomorrow

                          Kommentera


                          • #14
                            Lustigt. Är sökvägen till perl rätt? Det är det enda jag kan komma på.
                            Vissa dagar är man asfalten, andra dagar är man ångvälten.
                            Vissa dagar är man myggan, andra dagar är man vindrutan.

                            XML är som våld; löser det inte ens problem betyder det att man använder för lite.

                            Kommentera


                            • #15
                              Ja, det är rätt sökväg.
                              The future is today, worry about it tomorrow

                              Kommentera

                              Working...
                              X