Hej.
Jag har tidigare en kod som följer:
[kod]
string myTitle = "Sound/" + sTitel.ToString().Replace("å", "a").Replace("ä", "a").Replace("ö", "o").Replace("é", "e") + ".mp3";

string minSpelare = "<p></p><embed id=\"mediaPlayer\" type=\"application/x-ms-wmp\" src= " + myTitle + " width=\"300\" height=\"45\" autostart=\"true\" loop=\"false\" hidden=\"false\" controls=\"console\" volume=\"80\" type=\"audio/mp3\"></embed><p></p>";

[/kod]
I många år så har detta fungerat kanonbra, men den har nu slutat att fungera. Allt vad jag se är en rektangulär grå yta och inget ljud.

Efter en hel del sökande på Internet så fann jag denna kod:
[kod]
<object classid="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95" id="player" class="musicplayer-media" height="45" width="150">
<param name="url" value="<% =mySrc %>" />
<param name="src" value="<% =mySrc %>" />
<param name="name" value="musicplayer" />
<param name="showcontrols" value="true" />
<param name="animationatStart" value="true" />
<param name="volume" value="0" />
<param name="visible" value="false" />
<!--[if !IE]>-->
<object type="video/x-ms-wmv" data="<% =mySrc %>" class="musicplayer-media">
<param name="src" value="<% =mySrc %>" />
<param name="name" value="musicplayer" />
<param name="autostart" value="true" />
<param name="controller" value="true" />
<param name="volume" value="0" />
</object>
<!--<![endif]-->
</object>

string myTitle = "Sound/" + sTitel.ToString().Replace("å", "a").Replace("ä", "a").Replace("ö", "o").Replace("é", "e") + ".mp3";
string minSpelare = "<p></p><embed src=" + myTitle + " width=\"300\" height=\"45\" autostart=\"true\" loop=\"false\" hidden=\"false\" controls=\"console\" volume=\"80\" type=\"audio/mp3\"></embed><p></p>";
[/kod]
Denna fungerar underbart, med ett fel. När man loggar in på min sida, så visas denna som en grå fyrkant. Hur kan jag fixa detta?


[/kod]