Meddelande

Minska
No announcement yet.

Får ej @media att trigga

Minska
X
  • Filter
  • Klockan
  • Show
Clear All
new posts

  • Får ej @media att trigga

    Jag har ett problem med @media
    Jag har gjort 2 @media queries
    Kod:
    @media screen and (max-device-width: 480px) and (orientation: portrait) {
    	.no-mobile {
    		display: none;
    	}
    }
    @media screen and (max-device-width: 750px) and (orientation: landscape){
    	.no-mobile {
    		display: none;
    	}
    }
    När jag testar dom i Google Chrome's mobil simulering får jag dom bägge att trigga. I ios får jag den första att trigga men inte i den andra. I android triggar ingen.
    Jag har gjort 2 klasser för att testa
    HTML-kod:
    <div class="no-mobile">desktop</div>
    <div class="on-mobile">Mobil</div>
    Och dessa har jag slängt in på en utvecklingsite http://dev.ctc.se/

    Vad gör jag för fel?

  • #2
    båda klasserna i din CSS är ju .no-mobile är det rätt tänkt?
    "det går inte att lära en gammal norrlänning byta namn på irc" - gammalt kinesiskt uttryck

    Kommentera


    • #3
      Ja för jag har inte gjort några klasser för on-mobile än.
      Jag vill att div no-mobile skall döljas när man tittar i mobil.

      Inget förslag?

      Kommentera


      • #4
        Jag testade att gå in på sidan med en Samsung Galaxy S6, både Chrome och androids Internet-browser, och texten "desktop" syns inte. Det verkar alltså fungera enligt i önskemål i android?
        "Det finns tre sorters lögn; vanlig lögn, förbannand lögn och statistik" - Mark Twain

        Kommentera


        • #5
          Tack för info.
          Om du lägger telefonen i landscape, är även då desktop borta?

          Kommentera


          • #6
            Wibbskii skrev: Visa inlägg
            Tack för info.
            Om du lägger telefonen i landscape, är även då desktop borta?
            Svar: Ja
            "Det finns tre sorters lögn; vanlig lögn, förbannand lögn och statistik" - Mark Twain

            Kommentera


            • #7
              Tack för info.
              Bara för mig att fortsätta felsöka varför det inte fungerar på ios då.

              Kommentera


              • #8
                Kan det krocka om man har flera @media med samma inställningar?
                Tex.
                Kod:
                @media (max-width: 667px) {
                	.klass1{...}
                }
                @media (max-width: 667px) {
                	.klass2 {...}
                }

                Kommentera


                • #9
                  Fick rätt på det nu. Tror jag har en krock någonstans i min css fil. Bara att gå genom alla 5000 rader

                  Kommentera

                  Working...
                  X