Meddelande

Minska
No announcement yet.

Hjälp!!! UTF-8 Konvertering

Minska
X
  • Filter
  • Klockan
  • Show
Clear All
new posts

  • Hjälp!!! UTF-8 Konvertering

    Hej

    Detta är en fortsättning på mitt problem ställt i min tidigare tråd http://www.webforum.nu/showthread.php?t=194569
    tack prplxr!!

    Förutsättningar
    En MS Access databas som jag nu vill konvertera till MySQL databas.

    Problem
    Trots att alla konverterare (Bullzip MS Access to MySql & en Mac motsv) lovar att skriva ut det i utf-8 så blir alla å ä & ö så här �.
    Jag har även provat att konvertera i MySQL med hjälp av HeidiSQL utan framgång.

    När jag använder phpMyAdmin, som borde köra med utf-8, så syns tecknen helt ok men visar jag det på min hemsida, recept.solbo.se

    Vad f*piiip* är felet?
    Med vänlig hälsning

    Clownen

  • #2
    Jag hade samma fel som dig, fast åt andra hållet!
    Jag fick kluriga tecken, men bytte till UTF-8 och då blev det ordning på det.

    Jag fattar ingenting... Varken av mitt eget fel eller det du skriver!
    Jag har haft ISO tidigare, men helt plötsligt slutade det att fungera...

    <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">

    Kommentera


    • #3
      På ett eller annat sätt kanske denna funktion kan hjälpa dig:
      mb_convert_encoding()

      Antingen kan du konvertera vid output eller så konverterar du all data du har nu i din tabell med denna funktion.

      Kanske inte det smidigaste, men det kan mycket väl fungera.
      Avundas aldrig någon det sken av lycka han har för du känner inte hans hemliga sorger.

      Kommentera


      • #4
        Visst är det så att om jag vill ha en modern html5 hemsida i utf-8 så är det detta bra dokumenthuvud?

        HTML-kod:
        <!DOCTYPE html>
        <html lang='sv'>
        <head>
        <meta charset='utf-8'>
        (resten av koden här)
        När jag fipplade med detta så blev DB datan ok men åäö i själva html filen blev fel Med detta huvud är vi tillbaka på ruta 1.
        Med vänlig hälsning

        Clownen

        Kommentera


        • #5
          Det ser bra ut, det där, bortsett från att du använder enkelfnuttar. Du borde använda dubbelfnuttar då det är standard.
          Avundas aldrig någon det sken av lycka han har för du känner inte hans hemliga sorger.

          Kommentera


          • #6
            Tack, då kör vi på dubbelfnutt

            Kan rapportera att det verkar vara webhotellet, Binero, som är problemet.
            Satte upp samma hemsida på min NAS och där fungerar det perfekt.
            Med vänlig hälsning

            Clownen

            Kommentera


            • #7
              prplxr skrev: Visa inlägg
              Det ser bra ut, det där, bortsett från att du använder enkelfnuttar. Du borde använda dubbelfnuttar då det är standard.
              Enkelfnuttar fungerar precis lika bra som dubbelfnuttar.
              http://tumba25.net

              Kommentera


              • #8
                drew skrev: Visa inlägg
                Enkelfnuttar fungerar precis lika bra som dubbelfnuttar.
                Jag vet, det var därför jag skrev borde och inte måste.
                Avundas aldrig någon det sken av lycka han har för du känner inte hans hemliga sorger.

                Kommentera


                • #9
                  Det räcker tyvärr inte alltid med att ange charset i head. Själva dokumentet/filen/html-sidan måste vara SPARAD i utf-8 också. Då anges charset i filens meta-data (osynligt för ögat).

                  Om du berättar hur du skapar/sparar dina sidor så kan folk hjälpa till och berätta hur du ska göra.

                  Jester73 skrev: Visa inlägg
                  Visst är det så att om jag vill ha en modern html5 hemsida i utf-8 så är det detta bra dokumenthuvud?

                  HTML-kod:
                  <!DOCTYPE html>
                  <html lang='sv'>
                  <head>
                  <meta charset='utf-8'>
                  (resten av koden här)
                  När jag fipplade med detta så blev DB datan ok men åäö i själva html filen blev fel Med detta huvud är vi tillbaka på ruta 1.
                  Med vänlig hälsning från
                  Danne
                  ------
                  Proformica.com Marknadsföring, webbdesign, webbhotell osv, mm..
                  Sacred Skin Ny bok om Sak Yant, traditionell, spiritistisk thailändsk tatueringskonst
                  Våga Vägra
                  FaceBook

                  Kommentera


                  • #10
                    Jag hade ett liknande problem. Jag använde Windows anteckningar för att skriva koden och sparade i UTF-8.
                    Men jag började använda Notepad++ istället och där kan man välja under format att Koda i UTF-8 (utan BOM) vilket gjorde att även "mystiska tomma rader" på sidan försvann.

                    Men har även haft samma problem med Binero, ser inte lika ut på localhost som när det är upplagt på Binero.

                    Kommentera

                    Working...
                    X